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1. Introduction 

LinX Software Development Environment v4.0.3 is a preconfigured virtual machine containing 

development setup for many of CrossControl display devices. 

To be able to use LinX DevEnv 4.0.3 with the new CCpilot V700 display, an upgrade package 

is made for this. The upgrade contains of new CCLinux SDK, Qt runtime and patches to Qt 

Creator to configure a build kit for the CCpilot V700. This documentation describes how to do 

this upgrade. 

 

Instructions in this document is only valid for CCpilot V700 hardware REV 1.0+. 

2. Downloading the upgrade files 

To access the CCpilot V700 software, you need to log in to https://crosscontrol.com/ 

Register a user account if needed.  

Navigate to DISPLAY & COMPUTERS →CCPilot V700 where all related files can be 

downloaded. 

 

2.1. SDK and OS image version 

Make sure to upgrade your CCpilot V700 display to the latest OS image if you have an older 

install. It is possible to run the command “ccsettingsconsole --version” from the command line 

on the display to see your current OS version. If you already have the latest release available 

installed, skip the upgrade steps and only install the development environment files. 

https://crosscontrol.com/
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In section DOWNLOADS → DEVICE DOWNLOADS → CC LINUX → OS IMAGES the current 

Linux System Image is stored. All released versions are available so select the latest version or 

each file.  

• ccpilot-v700-linux-update-2.X.Y.Z-usb-stick.zip 

• ccpilot-v700-linux-rescue-update-2.X.Y.Z-usb-stick.zip 

• uuu-CCpilot-v700-X.Y.Z.0_release_image.zip 

In section DOWNLOADS → DEVICE DOWNLOADS → FIRMWARE the current SS 

application file is stored. All released versions are available so select the latest version or each 

file. 

• V700_SS_v1.X.Y.Z.hex (SS, System Supervisor version) 

2.2. Qt runtime 

Navigate to SOFTWARE & SOLUTIONS → CC Linux → DEV ENV DOWNLOADS → SDK → 

CCPILOT V700 and save the following ZIP file to your PC for later usage: 

• Select the latest SDK version available for the VM environment: 

o CCLinux-SDK-toolchain-x86_64-CCpilot-V700-2.X.Y.Z.sh.zip 

Navigate to SOFTWARE & SOLUTIONS → UX Designer → DEV ENV DOWNLOADS → 

SDK → CCPILOT V700 and save the following file to your PC for later usage: 

• Select the latest available Qt packages for the VM environment, currently:  

o linx-qt515-v700-dev_5.15.2-1_all.deb 

o linx-qt515-v700_5.15.2-1_all.deb 

Navigate to DISPLAYS & COMPUTERS → CCpilot V700 → DOWNLOADS → DEV 

DOWNLOADS → QT and save the following file to your PC for later usage: 

• Select the latest available Qt packages for the V700 target to your PC, for later usage: 

o linx-qt_5.15.2_v700.tar.gz 

o linx-qt_5.15.2_v700.sh 

2.3. Qt Creator 

To get the best experience with Qt 5.15, it is recommended to upgrade Qt Creator. Navigate to 

SOFTWARE & SOLUTIONS → UX Designer → DEV ENV DOWNLOADS → SDK → QT 

CREATOR and download the following files to your PC for later usage: 

• Select the latest available version of LinX UX Designer (Qt Creator), Qt runtime and 

templates from the download area, currently: 

o linx-ux-designer_4.14.0-2_amd64.deb 

o linx-qt515-vm_5.15.2-2_amd64.deb  

o linx-qtcreator-project-templates_1.1.0-beta.23_amd64.deb 
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2.4. DE/FA plugins 

The DataEngine (DE) and FieldbusAccess (FA) plugins are additional packages for the 

QtCreator tool. Navigate to SOFTWARE & SOLUTIONS → UX Designer → DEV ENV 

DOWNLOADS → SDK → QT CREATOR PLUGINS and download the following files to your 

PC for later usage: 

• Select the latest available Qt packages for the DE and FA plugins: 

o linx-manager-fieldbusaccess_2.0.0_amd64.deb 

o linx-manager-fieldbusaccess_2.0.0_amd64.deb 

o sapcore-dev_3.1..4-1_all.deb 

2.5. LinX widget objects 

Contact CrossControl support for information about the installation of LinX widget objects. 

https://crosscontrol.com/support/ 

3. Installation instructions 

3.1. Upgrade CCpilot V700 display 

3.1.1. OS Upgrade   

This step is only needed if the CClinux version of the display is older than the latest version 

available on the support site. There are two alternative ways to perform the OS upgrade.  

3.1.1.1. Alternative 1 - flash using uuu tool 

 
1. Extract uuu-CCpilot-v700-X.Y.Z.0_release_image.zip to a folder on your PC. 

2. Connect PC and CCpilot V700 display with a male – male USB cable. 

3. Reboot CCpilot V700 with the “force” pin (green connector on development cable kit) set 

high. 

4. Run “run-uuu” Windows batch file / Linux .sh script 

5. Wait until completed 

6. Reboot 

3.1.1.2. Alternative 2 – USB upgrade 

 
1. Extract ccpilot-v700-linux-update-X.Y.Z.0-usb-stick.zip to a USB stick 

2. File cc-auto.sh should be located in root folder, not extracted to a sub directory of the USB 

stick 

3. Enter USB stick to display 

4. Files will be copied to display, then it should reboot and do the system upgrade 

5. Repeat for ccpilot-v700-linux-rescue-update-X.Y.Z.0-usb-stick.zip 

3.1.2. System Supervisor upgrade (SS) 

 

https://crosscontrol.com/support/
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1. Reboot the display to rescue mode, with the “sudo reboot-rescue.sh” built-in script. 

2. Login again after reboot and check current SS version with these commands: 

 
3. Copy V700_SS_v1.0.1.0.hex (or newer) to /opt folder on the display using ssh or USB. 
4. Run the update with these commands: 

 

 
5. Turn off power to reboot the display. 
6. Log in again to verify with command “ccsettingsconsole --version=SS” that the new SS 

version is active. 
 

3.2. Update virtual machine environment 

Copy six of the earlier downloaded files to the LinX DevEnv v4.0.3. They will be installed in the 

virtual machine: 

• linx-ux-designer_4.14.0-2_amd64.deb 

• linx-qt515-vm_5.15.2-2_amd64.deb  

• linx-qt515-v700-dev_5.15.2-1_all.deb 

• linx-qt515-v700_5.15.2-1_all.deb 

• linx-qtcreator-project-templates_1.1.0-beta.23_amd64.deb 

• CCLinux-SDK-toolchain-x86_64-CCpilot-V700-v2.X.Y.Z.sh 

It can be done using shared folder or direct download from CrossControl support site with the 

built-in web browser in the virtual machine. The downloaded files are then located in the 

/home/ccs/Download folder. 

ccs@v700:~$ sudo su 

root@v700:/home/ccs# cd /opt/ 

root@v700:/opt# ccsettingsconsole --version=SS 

SSVersion: 1.0.1.0 

root@v700:/opt# ccsettingsconsole --advanced --update=SS --

filepath=/opt/V700_SS_v1.0.1.0.hex 

 

File format is correct. 

This operation may cause harm to your device. 

Do you wish to continue [yes/no]? 

 

yes 

 

This upgrade can take a few minutes to perform. 

Flashing 100 % 

Done 

SS successfully upgraded. 

Please shut down the computer and cut the power in order for the update to 

take effect. 

root@v700:/opt# 
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3.2.1. Install Linux SDK 

Run the following commands from a terminal window to automatically install SDK to the correct 

location. Make sure to replace X.Y.Z with the actual version number of the latest SDK. 

Make sure to use the exact same path for SDK install (/opt/V700 – Capital V) ... 

 

3.2.2. Install Qt and Qt Creator 

Qt Creator and Qt runtimes needs to be installed to be able to compile applications for CCpilot 

V700 display.  

It is important to install Qt Creator first in order to have kits automatically added to Qt Creator.  

 

In the case that this order is not followed, it is possible to reinstall linx-qt515-vm, linx-qt515-

v700 or linx-qt515-v700-dev after installing linx-ux-designer to solve this. 

Note that the kits will not be available in Qt Creator 4.8 (default version in LinX DevEnv 4.0.3). 

They are only added automatically to the new Qt Creator 4.14. 

3.2.2.1. Command line version 

Open a terminal window and type the following commands (password: default if requested) and 

follow the on-screen instructions: 

1. Begin with the Qt Creator: 

2. Follow up with Qt runtime for the virtual machine, V700 and finally template projects:  

$ sudo apt install ./linx-qt515-vm_5.15.2-2_amd64.deb  

$ sudo apt install ./linx-qt515-v700_5.15.2-1_all.deb   

$ sudo apt install ./linx-qt515-v700-dev_5.15.2-1_all.deb   

$ sudo apt install ./linx-qtcreator-project-templates_1.1.0-

beta.23_amd64.deb 

 

3.2.2.2. GUI version 

Open menu and select “System Tools” → “GDebi Package installer”. 

linx-ux-designer linx-qt515-vm linx-qt515-v700 linx-qt515-v700-dev

$ chmod +x CCLinux-SDK-toolchain-x86_64-CCpilot-V700-2.X.Y.Z.sh 

$ ./CCLinux-SDK-toolchain-x86_64-CCpilot-V700-2.X.Y.Z.sh -d /opt/V700 

$ sudo apt install ./linx-ux-designer_4.14.0-2_amd64.deb       



 
 

CCpilot V700 upgrade 

guide 

 
 

www.crosscontrol.com 8 

  

1. Select “File” → “Open file…” and navigate linx-ux-designer_4.14.0-2_amd64.deb 

2. Press “Install Package”. 

Repeat for the remaining packages: 

• linx-qt515-vm_5.15.2-2_amd64.deb 

• linx-qt515-v700_5.15.2-1_all.deb 

• linx-qt515-v700-dev_5.15.2-1_all.deb 

• linx-qtcreator-project-templates_1.1.0-beta.23_amd64.deb 

3.2.3. DE/FA plugins 

The DataEngine and FieldbusAccess Plugins are additional packages for the QtCreator to be 

able to create and maintain J1939-configuration and DataEngine signals. Close the QtCreator 

tool before installing the packages. 

Open menu in VM and select “System Tools” → “GDebi Package installer”. 

 

1. Select “File” → “Open file…” and navigate to the downloaded Debian package: 

linx-manager-dataengine_2.0.0_amd64.deb 
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2. Press “Install Package”. 

Repeat for the remaining packages: 

• linx-manager- dataengine _2.0.0_amd64.deb 

• linx-manager-fieldbusaccess_2.0.0_amd64.deb 

• sapcore-dev_3.1..4-1_all.deb 

When restarting the QtCreator tool, the plugins shall be visible in the vertical menu to the left. 

3.3. Install Qt on CCpilot V700 display 

1. Copy following files to the CCpilot V700 display “/opt” folder using WinSCP/SCP or USB 

transfer. 

a. linx-qt_5.15.2_v700.tar.gz  

b. linx-qt_5.15.2_v700.sh 

2. Log in to CCpilot V700 display using SSH  

a. User: ccs 

b. Password: default 

3. Run the linx-qt installer script from the terminal with the following commands: 

 

4. The installer will display information if the installation was successful or not. Verify the 

terminal output to determine the status of the installation 

3.4. Qt Creator 

Shortcuts for Qt Creator are added to the start menu and desktop with the installation of linx-

ux-designer. Use this version of Qt Creator to have an improved experience with CCpilot V700 

development. CrossControl Qt Creator template projects have also been updated to support 

CCpilot V700 with the installation of linx-qtcreator-project-templates. 

Use the following link to get more information on how to create and maintain Qt projects within 

the LinX Sw Suite v4.0: 

https://crosscontrol.com/software-solutions/linx-software-suite/ux-designer/ 

Navigate to the DOCUMENTATION tab and open the section “MANUALS”.  

Open the document “UX Designer Getting Started V4.0”. 

3.4.1. Using CCpilot V700 build kit 

The linx-qt515-v700-dev_5.15.2-1_all.deb package also adds the CCpilot V700 Qt build kit to 

the list of already pre-configured CrossControl displays computers (Qt Creator 4.14). It is now 

ready to be used. When creating a new project, mark it from the “Kit Selection” wizard page.  

 

$ chmod +x linx-qt_5.15.2_v700.sh 

$ sudo ./linx-qt_5.15.2_v700.sh 

https://crosscontrol.com/software-solutions/linx-software-suite/ux-designer/


 
 

CCpilot V700 upgrade 

guide 

 
 

www.crosscontrol.com 10 

 

 

 

3.4.2. Enable root SSH access 

To deploy, run or debug an application from Qt Creator, SSH access to the device is needed. 

When running a Qt application on the CCLinux OS, it must be executed as root. For security 

reasons, SSH root login is disabled by default so on development displays this must be 

enabled first during application development. By logging in to the display as user ccs, it is 

possible to enable root SSH access by modifying the ssh configuration file.  

From the terminal, type: 

 

Find and change the line: 

 

Change it to:  

 

Reboot or restart ssh service to enable root login via SSH. It is now possible to deploy, run and 

debug a Qt application as root to the CCpilot V700 display.  

The password for the added user ‘root’ is:   

 

$ sudo nano /etc/ssh/sshd_config 

#PermitRootLogin prohibit-password  

PermitRootLogin yes 

suseroot 
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3.4.3. Display output 

Qt for CCpilot V700 is pre-configured to use the eglfs_kms backend. For more information 

about this, please see the Qt documentation: https://doc.qt.io/qt-5/embedded-linux.html#eglfs-

with-the-eglfs-kms-backend 

 

It is also possible to use the plain eglfs backend if needed. Then these exports must be set in 

the Linux environment before running the Qt application to override the built-in eglfs_kms 

backend.  

  

export QT_QPA_EGLFS_INTEGRATION=eglfs_viv 

export QT_QPA_EGLFS_FORCEVSYNC=0 

export QT_QPA_EGLFS_FORCE888=1 

https://doc.qt.io/qt-5/embedded-linux.html#eglfs-with-the-eglfs-kms-backend
https://doc.qt.io/qt-5/embedded-linux.html#eglfs-with-the-eglfs-kms-backend
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Trademarks and terms of use 

© 2019-2020 CrossControl 

All trademarks sighted in this document are the property of their respective owners. 

CCpilot is a trademark which is the property of CrossControl. 

Linux® is a registered trademark of Linus Torvalds. 

Microsoft® and Windows® are registered trademarks which belong to Microsoft Corporation in 

the USA and/or other countries. 

Arm® is a registered trademark of Arm Limited (or its subsidiaries) in the US and/or elsewhere. 

Qt is a registered trademark of The Qt Company Ltd. and its subsidiaries. 

CrossControl is not responsible for editing errors, technical errors or for material which has been 

omitted in this document. CrossControl is not responsible for unintentional damage or for damage 

which occurs as a result of supplying, handling or using of this material including the devices and 

software referred to herein. The information in this handbook is supplied without any guarantees 

and can change without prior notification. 

For CrossControl licensed software, CrossControl grants you a license, under CrossControl’s 

intellectual property rights, to use, reproduce, distribute, market and sell the software, only as a 

part of or integrated within, the devices for which this documentation concerns. Any other usage, 

such as, but not limited to, reproduction, distribution, marketing, sales and reverse engineer of this 

documentation, licensed software source code or any other affiliated material may not be 

performed without written consent of CrossControl. 

CrossControl respects the intellectual property of others, and we ask our users to do the same. 

Where software based on CrossControl software or products is distributed, the software may only 

be distributed in accordance with the terms and conditions provided by the reproduced licensors. 

For end-user license agreements (EULAs), copyright notices, conditions, and disclaimers, 

regarding certain third-party components used in the device, refer to the copyright notices 

documentation. 

 


